A Simple Solution When Updating failed Saving Post in WordPress 5

How to fix the Gutenberg ‘Updating failed’ problem.

WordPress is a wonderful opensource project. But now and again it throws up strange oddities and errors that will prevent an easy workflow.

Recently, after spending an age restyling and modernising a very old WordPress blog, I ran into one of these strange oddities. The newly updated blog wouldn’t save or preview new posts.

What was the point of making the old blog pretty when I wasn’t able to publish new posts? Search after search revealed the same problem was bogging down many others. Gutenberg, the new post editor in WordPress seemed to have been at the root of the problem, or so it seemed.

After spending many hours trying to work through the, ‘Updating failed’ issue it was time to get to bed. I closed the laptop and decided to battle another day.

You can accomplish anything after a good nights rest

The following afternoon I opened up the laptop again. Determined to find a solution to this Gutenberg thing. Why was it preventing me from saving a new post or from previewing the new post in WordPress?

Then I remembered having another unused blog already set up right here on As both sites were on the same shared server, I would be able to see if it was the server setting causing the issue.

Some more experienced WordPress developers referred to the server settings as being the cause. And at this point, I had tried every other solution out there.

The WordPress blog was a clean, virgin installation. With no re-rights on the htaccess, no plugins and no custom theme – just what came out of the box.

Who knew the answer was this simple.

Success, writing a blog post caused no problems. I could write, save and even preview without any issue. So it wasn’t the server settings.

Then I remembered my old go-to fixer when it came to those strange oddities in WordPress that nothing else fixed. Here’s how that went…

First, I went back to the WordPress blog that couldn’t save or preview new posts using the new Gutenberg posts editor. I always use Google Chrome but this time, believe it or not, I opened Internet Explorer.

Amazing, I could post, edit, save and preview new posts in Gutenberg using Internet Explorer without any problems.

The answer was simple, all I needed to do was to Clear browsing data in Google Chrome. Yep, that did the trick! No more ‘Updating failed’ when saving new posts in WordPress 5.

Who would have believed it was that simple to fix the Gutenberg ‘Updating failed’ problem… Clear Google Chrome Browsing Data!

9 replies on “A Simple Solution When Updating failed Saving Post in WordPress 5”

Hi all here is the final solution: but let me give you some basic knowledge: 1. Please don’t change your permalink as it will affect your SEO Performance. 2. I have tried to disable all the plugin but there is no plugin error behind this issue. but my trick is does not work then you can check from your side by disabling all the plugin one by one.

So Here is the solution for this error:

This is work for me. may will for you.

Hi Anon,
Yep, sorry about all the words – my bad lol
I was on a bit of a roll when writing this trying to rank well in Google. Hope the solution fixed your issue 😉

Thanks for this article, i repeatedly tried to save my new article in my site , wordpress never allowed me to save. I was unable to edit existing posts too. I contacted the hosting and they said all things were fine. I am about to do what you mentioned, I hope this will work.

Excellent post. I was checking constantly this blog and I’m impressed!
Very useful info specifically the last part 🙂 I care for such information a lot.

I was looking for this certain info for a very long
time. Thank you and good luck.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.